Kubuntu Notes

Gutsy Gibbon

Fuzzy Fonts

After upgrading to gutsy, fonts might appear a little fuzzy. To fix this, go to System Settings > Appearance > Fonts and change the "Use anti-aliasing" box to "Enabled". Then click on the configure button and turn off sub-pixel hinting.

Compiz

Follow this tutorial: http://ubuntuforums.org/showthread.php?t=601310

You may need to turn on composite mode for X. To do this, you can run nvidia-xconfig --composite, which as far as I can tell just puts this in your xorg.conf:
Section "Extensions"
    Option         "Composite" "Enable"
EndSection
Restart X when you're done.

Make sure you enable the Window Decorations plugin in the compiz configuration manager, or you won't have borders for your windows!

The KDE pager and taskbar don't work with compiz. Install these instead: kicker-compiz, taskbar-compiz. Here's a kubuntu gutsy theme for emerald: http://tinyurl.com/2typn9. And here's some widget information: http://compiz.org/Desktop_Screenlets.

GTK Fonts and Themes

The GTK Fonts and Themes portion of the Appearance settings seems to have disappeared. If you want to prevent KDE from applying its themes to GTK applications (firefox, pidgin, etc.), go to Settings » Appearance » Colors and uncheck "Apply colors to non-KDE applications".

It turns out that Firefox doesn't behave well when KDE tries to apply themes to it, especially if KDE's current theme is dark.

General

Building source packages

If you need to build a package from source, download the source files and unpack them using APT. Next, change to the directory it created (something like package-1.2.3). You'll need to have dpkg-dev and fakeroot installed. Finally, run dpkg-buildpackage (ALERT! see the note below first before building) to build the package files (*.deb) which you can install via dpkg.

In summary: sudo apt-get install dpkg-dev fakeroot sudo apt-get build-dep <package> apt-get source <package> cd <package-1.2.3> dpkg-buildpackage -i -I cd .. dpkg -i <package-1.2.3>

ALERT! After installing the package you just built, apt-get dist-upgrade might install over your "self-built" package because it thinks its own version of the package is newer. To get around this, you can change the version of your package by using the dch command. You'll need to install the devscripts package to get this command. Run dch -i from the package source directory, and type a little note to yourself about why you're building the package from source. Then follow the above steps.

Using KWallet to store SSH passphrase

Here's a nice little page that describes how to use KWallet to store your SSH passphrase:
http://www.pontohonk.de/kde/ssh.html
Topic revision: r7 - 29 May 2009, WillGray
 

This site is powered by FoswikiCopyright © 2013-2022 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding Vanderbilt Biostatistics Wiki? Send feedback